We are continuing to monitor for any further issues.
Posted Mar 18, 2024 - 11:54 PDT
Monitoring
The issue has been resolved and we're monitoring the results.
Posted Mar 18, 2024 - 11:43 PDT
Identified
We've identified the issue with our upstream service provider and they are working on resolving the issue.
Posted Mar 18, 2024 - 10:05 PDT
Investigating
Our apps are currently down, we are currently investigating the issue.
Posted Mar 18, 2024 - 09:41 PDT
This incident affected: Wholesale Hub (Wholesale Hub - Storefront, Wholesale Hub - Admin, Wholesale Hub - Point of Sale), Ultimate Special Offers (Ultimate Special Offers - Storefront, Ultimate Special Offers - Admin, Ultimate Special Offers - Point of Sale), and Pixelpop.