Wholesale Hub Down

Incident Report for Orbit Apps

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 14:41 PDT

Investigating

We are currently investigating an issue with Wholesale Hub and will report back with updates.
Posted Aug 25, 2025 - 14:36 PDT
This incident affected: Wholesale Hub (Wholesale Hub - Storefront, Wholesale Hub - Admin, Wholesale Hub - Point of Sale, Wholesale Hub - Manual Orders).