Filterific admin down
Incident Report for Orbit Apps
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 00:16 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2024 - 23:48 PDT
Investigating
We are currently investigating this issue.
Posted Jun 04, 2024 - 21:59 PDT
This incident affected: Collection Filter.